Your Device Is Not Compatible With This Version2019-10-04T13:12:13+00:00
  1. Home
  2. Knowledge Base
  3. FAQs
  4. Your Device Is Not Compatible With This Version

The requirements needed to use iKydz Mobile on your Children’s devices are the following;

Android – iKydz Mobile is supported for all your kids’ Android mobile devices (Android version 7.0 and higher)

Apple – iKydz Mobile is supported for all your kids’ Apple mobile devices (IOS version 10 and higher)

 

 

Was this article helpful?

Related Articles